Introduction
This article provides detailed information on the error codes one might encounter when setting up the FlexNet licensing server for FME. Before proceeding, confirm that you are licensing FME with a floating license and not a fixed license. If you are having trouble with a fixed license, please see the Fixed License Troubleshooting article.
Complete instructions for setting up your floating license server are found in the FME Installation and Licensing Guide. Please ensure you have followed these steps before trying further troubleshooting. The floating license server installer can be found on our downloads page
If you want information on how to migrate from a fixed license to a floating license, please see our article How to Migrate Floating License Servers for complete information on migrating a floating license server.
- FlexNet Licensing error: -7,10015
- FlexNet Licensing error: -96,7: System Error: 11001 "WinSock: Host not found (HOST_NOT_FOUND)"
- FlexNet Licensing error: -125,147
- FlexNet Licensing error: -16,287
- FlexNet Licensing error: -15,10: System Error: 10061 "WinSock: Connection refused"
- FME Licensing Troubleshooting: EXITING DUE TO SIGNAL 15
Error Codes
FlexNet Licensing error:-7,10015
Issue:
The LMTOOLS service is not starting, and a message appears after clicking Perform Status Inquiry.
Causes:
• The wrong license file (not matching the hostname or the MAC address) is being used.
• Corrupted or expired license file.
Solutions:
1. Incorrect hostname or the MAC address
Use the generate HOSTID script to get the correct HostName and HostID, and then follow the steps mentioned at Request and Install the License.
2. Expired license file
If your organization has a subscription-based license agreement, please review the safe.lic file to check if the license is still valid, or else request a new license using the Floating License Request Form
Here is an example of an expired license file.
FlexNet Licensing error: -96,7 System Error: 11001 "WinSock: Host not found (HOST_NOT_FOUND)"
There could be multiple reasons why the server name is not getting recognized so here are a few points which can be taken care of if the error "License server machine is down or not responding. (-96,7:11001 "WinSock: Host not found (HOST_NOT_FOUND)")" is encountered.
1. Make sure the server is accessible, ping the server to see the response.
2. The port should be open /listening and not blocked by the firewall.
3. Add the server name and IP address to the file C:\Windows\System32\drivers\etc\hosts in Windows.
4. IP address can be specified in place of hostname if feasible.
5. Execute the commands below to check if there are any connectivity issues
Ping # <Hostname_of_license_server>
# Ping <IP_address_of_license_server>
# Telnet <IP_address_of_license_server> <Port_of_lmgrd>
# Telnet <IP_address_of_license_server> <Port_of_vendor_daemon>
# Lmstat -A -C <Port Atto Hostname_of_licsvr>
# Lmstat -A -C <Port Atto Ipaddr_of_licsvr>6. Hostname resolution should be in place.
7. Perform lmreread to make sure the correct configuration is taken into consideration.
The -96 error occurs when the license server is not started, or the license server cannot be accessed (due to a network failure, etc.)
FlexNet Licensing error: -125,147
Issue:
When running a diagnostic by clicking the Perform Diagnostics button on the Server Diags tab in LMTOOLS, the following message appears:
This license cannot be checked out because: A PACKAGE component must be specified. FlexNet Licensing error: -125,147
Solution:
Use the Perform Status Inquiry button on the Server Status tab in LMTOOLS to verify that the license file is being read successfully and to check the number of available licenses.
FlexNet Licensing error: -16,287
Issue:
- Error -16,287 indicates that the functionality timed out while waiting for the descriptor to become ready for read.
- Error -16,10009 indicates that the descriptor was ready for read, but during the read, an error was thrown.
From: the FlexNet Community
Solution:
In the Windows Search bar, Type "Run" and click OK.
In the run dialog, type "Services.msc" and click OK.
In the next dialog, search for FME License Server and select the item. Click "Restart the service" in the top left panel.
FlexNet Licensing error: -15,10: System Error: 10061 "WinSock: Connection refused "
Issue:
The license file may not have access to the correct ports or have a valid expiration date.
Verify if you are getting the following error: Go to All Programs → FlexNet for Safe Software → Launch LMTOOLS → As Administrator
Solution:
Ensure that the safe.lic file has correct ports and a valid expiration.
- Switch to the "Start/Stop/Reread" tab
- Click on Force Server Shutdown
- Click on Stop Server
- Click on the ReRead License file
- Click on Start Server
If you are still experiencing issues, try restarting the server from the Services.msc
In the Windows Search bar, type "Run" and click OK.
In the run dialog, type Open Services.msc and click OK.
In the next dialog, search for FME License Server, select the item from the list, then click "Restart the service" in the top left panel.
FME Licensing Troubleshooting: EXITING DUE TO SIGNAL 15
Issue:
Can not connect to the FME floating license server. The log file indicates the following: EXISTING DUE to SIGNAL 15. There may be an issue with restarting the Floating license server.
As shown in the safe.log:
(lmgrd) lmgrd will now shut down all the vendor daemons
(lmgrd) Shutting down safe pid=32553 because of signal 15
(lmgrd) Can't read from license server system. First try of shutdown safe failed.
(lmgrd) EXITING DUE TO SIGNAL 15 Causes:
- The FME License Service got corrupted.
- Shutting down the license server remotely.
Solution:
Option 1: Restart the FME License Service
Open LMTools.exe and click on Start/Stop/Reread table
- Click on Force Server Shutdown
- Press on Stop Server
-
Now Press on Start Server. If it still does not work.
- Click the Edit Advanced settings
- Then, under the Start Server Options, check the box for
Restrict lmdown to work only from node where lmgrd is running - Click the Save Advanced settings button
-
Click the Start Server button
Option 2: Check port connection using tnc
The Test-NetConnection cmdlet displays diagnostic information for a connection. It supports ping test, TCP test, route tracing, and route selection diagnostics. Depending on the input parameters, the output can include the DNS lookup results, a list of IP interfaces, IPsec rules, route/source address selection results, and/or confirmation of connection establishment. If the “TcpTestSucceeded” is true, that mean the communication is open, but if the result is “False.”that would imply that there is some network and we may need to involve the Network/Security team.
tnc licensing -port 27000 ComputerName : licensing
RemoteAddress: 10.212.101.96
RemotePort : 27000
InterfaceAlias : Safe Software
SourceAddress : 10.213.0.40
TcpTestSucceeded : True Check with your Network/Security team if there is a corporate firewall. If yes, ask them to run a network trace for both ports. Open ports in the corporate firewall to allow traffic.
Both ports (server and vendor ports) are defined in the safe.lic file needs to be opened as mentioned below:
Documentation: Specifying Floating License Server Ports
Article: Specify Port Numbers Used by FlexLM