The log file for Job ID <n> does not exist

Liz Sanderson
Liz Sanderson
  • Updated

Symptom

When viewing a job in the FME Server web user interface there is an error: 

The log file for Job ID <n> does not exist

And in Resources > Logs > Engine > Jobs there is no log file present for job <n>. 

 

Cause

This error is usually caused by one of three things: 

1. System Cleanup Tasks 

There is a System Cleanup task to remove job logs, by default this removes log files when they are 1 week old. If you try to view a log that is older than this clean up date, the log file will have been deleted by this clean up task and this error will be displayed. If the job log you are trying to view was run in the last 7 days then your machine may have undergone an aggressive system cleanup task which is triggered in low disk conditions.

2. The job is queued

The job is still in the QUEUED state, as in, it has not actually started running and therefore no log file has been created yet.

3. Job Submission problem

If the job failed it is possible the failure occurred upon job submission, this can happen if there is a problem with the initial request e.g. a problem with the value of one of the published parameters. 

 

Resolution

1. System Cleanup Tasks

The System Cleanup Tasks are configurable through the FME Server Web UI by the system administrator under the System Configuration > System Cleanup page. To change the age at which job logs are deleted edit the Remove Files Older Than parameter for the Delete_Job_Logs Task. 

If you are experiencing low disk conditions (you can confirm this by viewing the fmecleanup.log in Resources > Logs > Service > current|old) you should look into freeing up some disk space on your FME Server host machine to stop the emergency cleanup. 
You can increase the threshold at which to perform an aggressive cleanup is triggered under System Configuration > System Cleanup > Configuration in the Web UI. To disable low disk conditions entirely, set the values to zero. 

In FME Server 2016.0 and older the cleanup tasks were configured by editing the fmeServerConfig.txt. Make sure you check the documentation specific to your version for correct instructions. 

 

2. The job is queued

There are a number of reasons your job could be stuck in a queued state, check out the article FME Server Jobs go straight into 'Queued' state and never run for further troubleshooting help. 

 

3. Job Submission problem

On the Job page view the 'Result Data' section and look for the statusMessage, this should inform you as to what went wrong and where to focus your troubleshooting efforts. 

 

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