Symptom
When viewing a job in the FME Flow there is an error:
The log file for Job ID <n> does not exist
And in Resources > Logs > Engine > Jobs there is no log file present for job <n>.
Cause
This error is usually caused by one of three things:
1. System Cleanup Tasks
FME Flow runs automated System Cleanup tasks that are triggered by schedule or disk conditions. You can confirm if a cleanup task has been run by viewing the fmecleanup.log (Resources > Logs > Service > current|old).
Default Cleanup
By default, scheduled cleanup tasks remove job logs over 1 week old. If you attempt to view a log that has been deleted by this task, you may receive this error.
Low Disk Conditions Cleanup
If the missing job log was run within the last 7 days, it is possible that an aggressive system cleanup task occurred due to low disk space. In environments with critically low memory, log files may be deleted immediately after job submission.
2. The Job is Queued
The job is still in the queued state. When a job is queued, it has not started running, and therefore, no log file has been created yet. This may occur when the engines are offline, unlicensed, or occupied with other jobs.
3. Job Submission Failure
When a job fails before it starts running, it receives a job ID but does not produce a job log. This usually means that there was an error with the job submission, for example:
- Published parameter values are invalid
- Private parameter values are invalid
- A Python start-up script failed
Resolution
1. System Cleanup Tasks
Default Cleanup
System Cleanup tasks are configurable through the FME Flow Web UI. Administrators can access those settings via System Configuration > System Cleanup > Scheduled Cleanups.
To change the frequency at which job logs are deleted, locate the Delete_Job_Logs task and update the Remove Files Older parameter.
Low Disk Conditions Cleanup
If you are experiencing low disk conditions, increase available disk space in your FME Flow environment.
The threshold for a disk conditions cleanup is configurable in the System Cleanup task settings. Administrators can access those settings via System Configuration > System Cleanup > Configuration. To disable low disk conditions entirely, update all Low Disk Conditions values to zero.
2. The job is queued
There are numerous reasons a job becomes stuck in a queued state, e.g. licensing, queue control rules, engine failure, etc. Therefore, the resolution may vary. Review "FME Flow Jobs go straight into 'Queued' state and never run" for further troubleshooting.
3. Job Submission problem
For many job submission errors, an error may be recorded in another log and viewed in the Web UI.
On the job page, expand the 'RESULT DATA' section and look for the "Status Message" parameter. This parameter may provide a more detailed error message.
Python errors are not recorded on the job page. Review “My Python script fails on FME Flow, but error messages are missing or insufficient” for further troubleshooting.
Lastly, other system logs may contain information about the failure, such as the fmeserver.log and fmeprocessmonitorengine.log. Review "Tips for Troubleshooting with Logs" for further troubleshooting tips.
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