Known Issue: FME Server Can't Connect to Core or Communicate with Host Due to Ports Already in Use by AnyDesk Application

Sanae Mendoza
Sanae Mendoza
  • Updated

Symptoms

  • FME Server is not loading completely in the web browser. You may only see the "Backup and Restore" page. 
  • Error messages when opening web browser: 
"Error communicating with FME Server host" 
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"FME Server could not connect to FME Core"
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  • Possible errors found in the fmeserver.log and fmeconfiguration.log files:

1.

An error occurred while running the post-install scripts: The post-install scripts were unable to create the necessary connections to FME Server.

2.

Unable to connect to process during startup. Failed to connect to host localhost on port 707-

3.

org.postgresql.util.PSQLException: Connection to localhost:7082 refused. Check that the hostname and port are correct and that the postmaster is accepting TCP/IP connections.

 

Cause

AnyDesk Virtual Machine application uses port 7070 by default which conflicts with one of FME Server's required ports. Other port conflicts may also be occurring on 7500 or 7076 (possibly others). 
 

Resolution

Check if AnyDesk is using port 7070 and change it in the settings ("Settings" > "Connection" > "General") to a port that's not required by FME Server's required ports. Restart the machine to apply the updated port. 

If you are using a port pool for Distributed Engines, make sure the updated AnyDesk port is not in the pool as defined in fmeServerConfig.txt in FME_SERVER_PORT_POOL (more details here).

If this doesn't resolve the issue, confirm what port services are in use by AnyDesk, and disable services that conflict with FME Server's ports. 


Windows

1. Open Command Prompt as an Administrator. To retrieve a list of ports and services, run the following command. 
netstat -ano

2. The final column is the PID number, to retrieve the service name associated with this PID run:

tasklist /fi "pid eq <PID>"
This information can also be found in Windows Task Manager under the Details tab.  

4. If any of the required FME Server ports are in use by AnyDesk (or another service), you will need to free this port in order to successfully access FME Server. In Task Manager select 'End Task'. Alternatively, you may wish to re-configuring FME Server to use a different port to avoid future conflict.  

5. Restart the FME Services and make sure FME now occupies this port by rerunning Steps 1 and 2. 


Linux

1. Open the console as the root user. To retrieve a list of ports and services, run the following command: 
netstat -apn  
2.  If any of the required FME Server ports are in use by AnyDesk (or any other service), you will need to free this port in order to successfully access FME Server. End those processes. Alternatively, you may wish to re-configuring FME Server to use a different port to avoid future conflict.  
kill <PID>
3. Restart the FME Services and make sure FME now occupies this port by rerunning Step 1. 


Run Post-Configuration Scripts

Now that FME Server has access to all the required ports, manually run the post-configuration scripts to ensure all the components are correctly installed. 

1. Run the scripts in <FMEServer Install Directory>/clients/utilites as admin. In Windows, they are *.bat files. In Linux, they are *.sh files. 
a. AddCleanUpTasks
b. AddPublishers
c. AddQueueNode (2018 only)
d. AddServices
e. AddSubscribers
f. configureDemoWorkspaces
 
2. Restart FME Server Services

3. Log into your FME Server web application.

 
If you are still experiencing issues please consult our Web Interface troubleshooting guide. If this does not resolve your problem then contact Safe Software Support.  

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