FME Version
Known Issue ID | FMEFLOW-25323 |
Feature | Engine Management |
Product | FME Flow |
Versions Affected |
2025.x 2024.x |
Status | Unplanned |
Issue
After upgrading an FME Flow express installation to 2024.0 or later and restoring a backup containing engine assignment rules, jobs go to the queue and won't run.
Cause
Engine assignment rules created in an earlier version of FME Flow reference an engine hostname, instead of localhost.
Starting in FME Flow 2024, when performing an express installation, the installer only prompts for the external hostname used to access the instance. Localhost is used elsewhere in the config files to keep communication local and help avoid issues with hostname resolution.
This means that engines will now always be named localhost_Engine#, where # is the engine number, by default.
In earlier versions of FME Flow (formerly FME Server), a hostname was specified when performing an express installation, and that hostname was used in the engine name. For example, myhost_Engine1.
When restoring a backup with assignment rules configured using an engine hostname instead of localhost, FME Flow preserves the engine hostname used previously. As a result, jobs going to a queue assigned to an engine previously named myhost_Engine1 will never run, because the engine is now named localhost_Engine1.
Workaround
1. Update engine assignment rules (recommended)
Under Engine Management, on the Engine Assignment Rules page, click on each rule that references the old engine hostname and update it to the new localhost engine name. For help, please see Getting Started with Queue Control.
This is a one-time change. You will not need to make this change on subsequent upgrades from FME Flow 2024 and later.
2. Change the engine hostname
You can change the engine hostname name via the processmonitorconfigengines.txt:
- Set NODE_OVERWRITE to true
- Change the ENGINE_HOST_NAME value from localhost to your hostname
- Restart FME Flow (this will put the change into the system DB)
- Comment out NODE_OVERWRITE
We don't recommend making this change unless there is a specific reason due to the possibility of communication and network issues arising. This change will also not be preserved on future upgrades of FME Flow and will need to be reapplied.
Resolution
See workaround. If you are still experiencing issues, please submit a support ticket.
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