Known Issue: FME Flow System Backup Fails with Error “929029:Unable to export”

Matt Meeboer
Matt Meeboer
  • Updated

FME Version

Known Issue ID FMEFLOW-23068
Discovered 2023.0
Affects 2023 all versions
Resolved 2024.0

 

Symptom

The FME Flow System Backup action fails with the error below in the log file when trying to export connections:

929029:Unable to export: Error: null

This error may also occur when exporting an FME Flow Project that contains connections.

 

Cause

This issue is randomly caused when a database connection is modified in FME Flow. When the database password is saved, it is encrypted. If the resulting encrypted password contains certain special characters, it cannot be exported as part of a backup or project. At this time, only database connections are known to be affected by this issue.

 

Workaround

Avoid modifying database connections in FME Flow 2023. Use FME Form to modify the connection and republish it to FME Flow.

If you do not have many database connections, you can try the steps below. If your server has too many connections to make manual troubleshooting feasible, please submit a support ticket for assistance.

To find the database connections that are causing problems: 

  1. In the FME Flow Web UI, create a Project with all your database connections.
  2. Try to export the project. Confirm that you receive the same error.
  3. Start removing connections from the package and try to export each time until the export is successful and you have found the connection(s) causing the problem.
  4. Note the connection settings, or export it from FME Form, so that it can be recreated later. 
  5. Remove the problem connection(s) from FME Flow.
  6. Try to export the package again. If the export succeeds, retry the system backup via Backup & Restore > Create Backup and confirm it succeeds.
  7. Manually recreate the connection(s) in FME Form and publish them to FME Flow.
  8. Try to backup again. Confirm that the backup action still succeeds with the recreated connection(s).

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