FME Version
Known Issue ID |
FMESERVER-19601 |
---|---|
Discovered |
2022.0 |
Affects |
2022.0 + |
Resolved |
2022.2 b22787 |
Symptom
Web connections are missing after the restore process during an upgrade.
Cause
You will see this issue if you were affected by the bug described in Known Issue: ArcGIS Online Web Services are Invalid. This was found in the ArcGIS Online Web Service but may affect other web services.
Before attempting to upgrade your FME Server please follow the steps below:
Go to your Web Services page on FME Server.
Right-click and select Inspect to open Developer Tools in your web browser. Select Network, then Refresh the page. Finally, find web services under the name section and select it.
Then, copy the results and paste them into a text editor.
Then, search for the text document for authorizationUrl. The authorizationUrl should have a value, if you see authorization URLs that are blank take note of the name of the Web Service.
Find the web service in the FME Server UI and remove it. Note: This will remove all web connections related to the web service. However, it is unlikely that these web connections are working. If you do have a web connection associated with an invalid web service that works, please reach out to our support team.
For more information on how these invalid web services can be created, see Known Issue: ArcGIS Online Web Services are Invalid.
Resolution/Workaround
Remove any invalid Web Services before taking a backup of your current FME Server. If you do this, then the Restore will be successful.
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