Symptom
On Citrix, FME Desktop does not start up
When starting FME Workbench, FME Data Inspector or FME Viewer on Windows Desktop being delivered to clients via Citrix application you may receive this error message:
Runtime Error! Program: Y:\Apps\FME\fmeworkbench.exe R6030 - CRT not initialized
FME Desktop does not start up, gives "DLL could not be loaded" error
FME Desktop does not run, and gives a warning message similar to:
WARN |DLL 'C:\Program Files (x86)\FME\xxxx.dll' was found but could not be loaded. Ensure that all the dependent modules exist for this DLL
This warning may be followed by errors such as:
ERROR |This FME edition does not recognize the `xxxxxxxxx' reader. Please ensure that the current platform supports this reader, the reader name is spelled correctly, and that you have installed all required plug-ins.
FME Installation fails
The FME install fails with an message such as "Setup Wizard ended prematurely because of an error" or similar.
Cause
These errors and others are usually caused by the Microsoft Visual C++ Redistributable not being installed as part of the FME Desktop installation. Potential reasons for the failure include:
- User Account Control (UAC) settings on the system prevent the installation
- The FME installer was corrupted during download
- The Windows Installer (used to install *.msi files) on the system is not up to date
Resolution
In order to resolve this issue, it may be possible to simply install the Visual C++ Redistributable after installing FME. It is available on the FME installation media, or as a download from Microsoft:
- What Microsoft Redistributables are required for FME: to find the appropriate version to download
The redistributable is backwards-compatible, so the latest version should work for all releases of FME.
If this does not resolve the issue, please take the following steps:
- Ensure that Windows Installer is up-to-date. This can be done by running Windows update, or installing it manually via the most recent link in the results at http://search.microsoft.com/en-ca/DownloadResults.aspx?q=windows+installer.
- If you are using a downloaded FME installer, consider downloading it again to ensure that your copy is not corrupted. Alternatively, see instructions below for verifying the installer.
- Uninstall FME if the previous installation succeeded.
- Run the FME installer as an administrator by right-clicking on the installer and selecting "Run as administrator"
If the issue persists, please follow the steps in the General Troubleshooting article and contact the Product Support Team.
Validating the installer
Downloading the FME MSI installer can sometimes corrupt the file, due to network errors or antivirus scanners.
In order to verify the integrity of your installer, it is possible to calculate a checksum or hash, and compare it to that of the original file.
One freeware utility to calculate these hash values is Hash My Files (http://www.nirsoft.net/utils/hash_my_files.html). Unzip the program, drag and drop the *.msi file onto it, and send the MD5 and SHA1 hash values along with the reported file size and the installer filename (i.e. fme-desktop-b12258-win-x86.msi) to the Product Support Team.
We can then compare the values with the files on our FTP site.
Installer Logging
It may sometimes help us if you send us a detailed installer log. You can generate an installer log by running the install on the command line, i.e.:
msiexec /i "C:\tmp\fme-desktop-b12258-win-x86.msi" /l*v install.log
and sending us the install.log file.
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