Known Issue ID | FMESERVER-16268 |
---|---|
Discovered | 2019.2 |
Affects | All Versions |
Resolved | N/A |
Symptom
In FME Server when I go to the Jobs Completed page I receive a toast message:
There was an error retrieving the jobs
If I view the response in Developer Tools (or call the REST API endpoint directly) the detailed message refers to an invalid XML character, for example:
{"message":"org.dom4j.DocumentException: Error on line 1 of document : An invalid XML character (Unicode: 0x7f) was found in the value of attribute "value" and element is "NM_DIRECTIVE". Nested exception: An invalid XML character (Unicode: 0x7f) was found in the value of attribute "value" and element is "NM_DIRECTIVE"."}
or
{'message': 'org.dom4j.DocumentException: Error on line 1 of document : An invalid XML character (Unicode: 0x7f) was found in the value of attribute "value" and element is "PROPERTY".'}
Cause
The corresponding data in the database table is stored as binary data but due to some invalid XML it cannot be decoded. Invalid XML can be present for a variety of reasons, those known include the event message received by a workspace from an email trigger and the final error message in a translation log.
Workaround
This issue has previously been encountered using the email trigger in Automations where there was invalid XML in the email body, in this scenario, there were two workarounds that were suitable for these users:
Option 1: Filter offending event message so it does not trigger a workspace
The invalid XML was caused by something in the email body, but in this case, the email trigger was monitoring an inbox where not every email actually needed to be processed, only those with a specific email subject. A filter was added between the email trigger and run workspace action so that only valid emails were submitted for processing.
Option 2: Remove the offending key from the event message parsed to the workspace
The invalid XML was caused by something in the email body, but in this case, only the email subject was actually being used in the downstream workflow. Therefore to resolve this error we unchecked the email.body event key so it was not included in the output message that was parsed into the run workspace action:
Additional Troubleshooting
If the above workarounds are not suitable for your workflow, please perform the following query on the FME Server database (where <n> is the ID of the job causing the error), save the response and submit a case with Safe Software Support. Other details to include should be how the workspace was submitted and the detailed error message from Developer Tools.
SELECT * FROM fme_job_history WHERE job_id = <n>
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