ArcGIS Licensing Error: Unable to Perform Licensing Related Tasks

Liz Sanderson
Liz Sanderson
  • Updated

Symptom

Attempting to use an ArcGIS Geodatabase format results in the following error messages:

"Unable to perform any licensing related tasks. Please check your Esri ArcGIS Compatibility workspace parameter, found in Navigator -> Workspace Parameters -> Translation. This 64-bit version of FME requires ArcGIS Desktop along with 64-bit Background Geoprocessing; ArcGIS Pro; or ArcGIS Enterprise. Refer to this this article http://fme.ly/qua for more details " (FME 2022.1) 

Or

 

"Unable to perform any licensing-related tasks. Please ensure that ArcGIS Desktop/Engine Runtime is correctly installed"


Or

INFORM|The Esri Product license used by this machine does not include licenses for the 'ArcInfo' licensing level

ERROR |Unable to perform licensing-related tasks. Please ensure that ArcGIS is correctly installed


Or

The Product License has not been initialized.


Cause

This error occurs for various reasons related to your ArcGIS Licensing Configuration, for example:

  • The ArcGIS license is expired
  • The ArcGIS license server is not available
  • The licensing level is insufficient
  • The ArcGIS installation is not licensed correctly
  • Environment Variables incorrectly set.


Resolution

  1. Ensure the ArcGIS license is still current and active.
  2. Check that the licensing server is available: Unable to connect to ArcGIS License Manager 
  3. Have you upgraded the software recently? Do you have more than one Esri Product on the same system:
    • Review Environment Variables in case some were set with previous software.  ESRI_SOFTWARE_CLASS
    • If using ArcGIS Background Processing 64-bit, FME could be finding this instead of ArcGIS Pro.
  4. Check the licensing level is adequate:
    • Required ArcGIS license types for FME Geodatabase formats
    • Setting different license levels for ArcGIS and FME with ESRI_SOFTWARE_CLASS environment variable
  5. Review that the installation is licensed correctly, as follows:
    • Ensure that your ArcGIS installation is on the same machine as the FME installation.
    • Use the ArcGIS Administrator application to check the availability of ArcGIS licenses. 
    • The Esri ArcGIS should be installed with the ‘All Users’ option to make sure FME has access to the license. See below. 

ArcGISPro Licensing


Additional Resources

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.