Symptom
The FME Flow Web UI is not accessible (cannot login) and the following error is displayed in the catalina.log for Tomcat (<TomcatDir>\logs).
21-Jun-2016 10:45:26.524 SEVERE [localhost-startStop-2] org.apache.catalina.session.StandardManager.startInternal Exception loading sessions from persistent storage java.io.EOFException at java.io.ObjectInputStream$PeekInputStream.readFully(ObjectInputStream.java:2335) at java.io.ObjectInputStream$BlockDataInputStream.readShort(ObjectInputStream.java:2804) at java.io.ObjectInputStream.readStreamHeader(ObjectInputStream.java:802) at java.io.ObjectInputStream.<init>(ObjectInputStream.java:299) at org.apache.catalina.util.CustomObjectInputStream.<init>(CustomObjectInputStream.java:95) at org.apache.catalina.session.StandardManager.doLoad(StandardManager.java:209) at org.apache.catalina.session.StandardManager.load(StandardManager.java:162) at org.apache.catalina.session.StandardManager.startInternal(StandardManager.java:356) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147) at org.apache.catalina.core.StandardContext.startInternal(StandardContext.java:5272) at org.apache.catalina.util.LifecycleBase.start(LifecycleBase.java:147) at org.apache.catalina.core.ContainerBase.addChildInternal(ContainerBase.java:725) at org.apache.catalina.core.ContainerBase.addChild(ContainerBase.java:701) at org.apache.catalina.core.StandardHost.addChild(StandardHost.java:717) at org.apache.catalina.startup.HostConfig.deployWAR(HostConfig.java:939) at org.apache.catalina.startup.HostConfig$DeployWar.run(HostConfig.java:1812) at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) at java.util.concurrent.FutureTask.run(FutureTask.java:266) at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1142) at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:617) at java.lang.Thread.run(Thread.java:745)
Cause
The Tomcat Web Application Server did not properly shutdown and some of the supporting files are either corrupt or cannot be refreshed.
Resolution
1. Stop the FME Flow Application Server Windows Service
2. Navigate to <TomcatDir>\work\Catalina\localhost\ (e.g. C:\apps\FMEFlow\Utilities\tomcat\work\Catalina\localhost\)
3. Delete all folders starting with fme (e.g. fmeaws, fmecatalog, ...)
4. Start the FME Flow Application Server Windows Service
Comments
0 comments
Please sign in to leave a comment.