Known Issue ID |
N/A |
---|---|
Discovered |
2022 |
Affects |
All versions |
Resolved |
N/A |
Symptom
I cannot set up an ArcGIS Online connection or my previously working ArcGIS Online connection no longer works.
Cause
This behavior is linked to ArcGIS Online web connections that make use of FME's out-of-the-box ArcGIS Online web service. ArcGIS Online web connection utilizes an ArcGIS Online web service that connects to an application created by Safe Software. If a particular security setting in ArcGIS Online is enabled, it can prevent users from using external apps. This can lead to the FME web service being disabled.
To determine if this setting is enabled, log in to ArcGIS Online with an admin account. Go to "Settings" and then "Security". Look for "Apps" and check if "Members can only sign in to external apps that are approved" is enabled.
Resolution/Workaround
Option 1 (Preferred)
Register your own application with your organizational ArcGIS Online account for FME. This will provide you with your own Client ID and Client Secret which can be used to create a new ArcGIS Online web service in FME. It is recommended to use the ArcGIS Online Web Service definition provided by Safe Software for demo purposes only. Instructions on how to do this can be found in How to Create an ArcGIS Online Web Connection (OAuth 2.0).
Option 2
Turn off the security setting or try adding the FME application (Client ID OSNnG92IVpxtDLHf) to the approved application list.
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