Esri File Geodatabase (API) Error (-2147220109): Compression Not Installed

Liz Sanderson
Liz Sanderson
  • Updated

FME Version

  • FME 2015.x

Symptom

When attempting to read a Geodatabase using the File Geodatabase (Geodb API) Reader, an error is encountered:
 |WARN |Geodatabase Error (-2147220109): FileGDB compression is not installed. |WARN |Could not open File Geodatabase table `MyTable'

Cause

The Geodatabase has been compressed in ArcGIS for Desktop using the "Compress File Geodatabase" tool. The Esri File Geodatabase API does not support reading compressed data and fails.

Resolution

There are two methods to correcting this issue:

1) Use the following Esri Geodatabase Writer: Esri Geodatabase (File Geodatabase ArcObjects)

OR

2) Uncompress the Geodatabase using ArcCatalog tools. (Administration > Uncompress File Geodatabase)

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.