Esri File Geodatabase (API) Error (-2147220965): Geodatabase is Either Invalid or Out of Date

Liz Sanderson
Liz Sanderson
  • Updated

FME Version

  • FME 2015.x

Symptom

When reading a ESRI File Geodatabase using the File Geodatabase API the following Error occurs: Geodatabase Error (-2147220965): This release of the GeoDatabase is either invalid or out of date.

Cause

This error is produced when reading older versions of ESRI File Geodatabase. Only version 10 or newer File Geodatabases are supported by the File Geodatabase API.

Resolution

Only version 10 or newer File Geodatabases are supported by the File Geodatabase API. Upgrade the Geodatabase using a newer version of ArcCatalog (Right Click > Properties > Upgrade Status).

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.