Problem Publishing to FME Server using Web Connection

Liz Sanderson
Liz Sanderson
  • Updated

FME Version

  • FME 2015.x

Symptom

When trying to publish to FME Server you see the following error:

 Error Communicating with FME Server, FME Server may not be running...

 

Cause

Causes include:

1) The FME Server Services are not running.

2) FME Server has been installed with a non-standard port number and the port has not been specified in the URL.

3) If your computer is using a proxy server to access the internet you may need to configure FME Workbench to use the proxy server when publishing workspaces to FME Server using the Web Connection.

 

Resolution

Restart FME Server:
Restart the FME Services on the Server using the steps listed here. Once you have confirmed that the server is running, try publishing again.

Use a Correct URL:
Make sure to enter the non standard port in the URL: http://<host>:<port>

Use the Web Connection with a Proxy Server:
If your internet access comes to you via a proxy server, please try the following:

  1. Configure FME Workbench to use your system proxy settings by going to Tools > FME Options > Network and check the box that says Use system proxy settings. Fill in the authentication information if required by your proxy server.
  2. Test that the proxy settings are working in FME Workbench by going to Help - Check for Updates. If FME cannot check for updates then you may need to ensure that your system is configured to use your proxy server.Save your workspace if necessary
  3. Restart FME Workbench.
  4. Try again to publish your workspace to FME Server.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.