FME Version
Symptom
On occasion a translation may appear to stop running as no more lines are printed to the log window in Workbench for an extended period of time or to the log file.
You may be running the translation through Workbench, the command line or even through FME Server. Typically the log file output will show something like this (if writing):
...
2015-01-09 14:57:08|8706.5| 0.2|INFORM|MULTI_WRITER: multi_writer_id `1': Writing feature 507000
2015-01-09 14:57:09|8706.6| 0.1|INFORM|MULTI_WRITER: multi_writer_id `1': Writing feature 508000
2015-01-09 14:57:09|8706.7| 0.1|INFORM|MULTI_WRITER: multi_writer_id `1': Writing feature 509000
2015-01-09 14:57:10|8706.9| 0.1|INFORM|MULTI_WRITER: multi_writer_id `1': Writing feature 510000
There will be no further output in the log file and it will appear as if FME has halted or hung processing of the Translation. This could occur at anytime during the translation - some translations may hang during source data reading, others while running through a transformer or as in the example above while writing out features.
Cause
If this is encountered, it usually means the available disk space has been completely consumed by temporary files. FME can make use of temporary files during the translations and on large datasets it can use many GB's of temporary space on the hard drive.
Resolution
- Check your temp folder and clear any files that may be hanging around from the FME process. If FME does create temporary files during processing they can be up to 1.5GB in size. Normally these are removed when the Translation completes but during a crash or unfinished translation they can be left behind.
- On Windows systems, empty your Recycle Bin - deleting files will place the files in your Recycle Bin but will still consume disk space until your Recycle Bin has been emptied.
- Ensure you have ample free disk space and try running the translation again.
NOTE:
By default FME will use %TEMP% on Windows systems for creating temporary files unless the system environment variable FME_TEMP exists. If FME_TEMP exists, FME will write temporary files to that location, however, some third party plugins used by FME may still use the %TEMP% directory, so it is best to check both locations.
Some temp files are not cleaned up properly leaving behind large temporary files. If FME has completed the translation successfully and is leaving temp files behind please report these to us with the workspace and data so we can reproduce the situation and ensure the temp files are properly removed after use.
TIPS:
Make use of FME_TEMP system environment variable to control where FME creates the temporary files.
Make use of Solid State Drives (SSD) for your temp files. We've heard of impressive performance gains from customers using SSD hardware with large translations.
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