Workspace Fails Using FME Flow - Data in Mapped Drive

Kate B
Kate B
  • Updated

Symptom

A workspace that runs on FME Form (formerly FME Desktop) fails to run on FME Flow (formerly FME Server). The error in the web user interface may say, "FME Flow transformation failed: A fatal error has occurred. Check the log file above for details."

The FME log itself may show various reader or writer errors indicating the reader could not open the source data file/directory or write to a directory.

 

Cause

On Windows, FME Flow runs as a Windows Service that starts before the operating system defines mapped drives. FME cannot understand the drive mappings. It cannot find source data with mapped drives in the file path or write to mapped drives.

 

Resolution

File paths in workspaces can be defined with UNC paths rather than mapped drives if your workspace is reading from or writing data to a network drive. For example, you may have a source data path in your workspace like this:

Z:\SourceData\MyFile.mdb

You must find out the computer name and path that your Z: drive is mapped to and modify the file path in your workspace to use the UNC convention. For example, your Z: drive may be mapped to a computer named Server1 and a directory called Data.

Your UNC path would then look like this:

 \\Server1\Data\SourceData\MyFile.mdb


Important Note:

By default, the FME Flow Windows services are not started by a true network user. If a workspace run by FME Flow needs to access a UNC or network file path for reading or writing, you must modify the user and password of the FME Flow Windows Service. Instructions for changing the service user can be found here.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.