FME Version
Known Issue ID | DEVOPS-2470 |
---|---|
Discovered | 2022.0 |
Affects | 2022.0+ |
Resolved | 2022.2 |
Symptom
After installing FME Server 2022.0 on Windows Server in French System Locale, the FME Server services cannot be started. Looking at Windows Services, the four FME Server Services (FME Server Application Server, FME Server Core, FME Server Database, and FME Server Engines) are not running. If you try to start the services, an error 1067 or 1069 will appear.
Cause
In the C:\Program Files\FMEServer\Config\values.yml file, the system encoding for the system account (systemuser) “Système” causes issues with the installation.
Workaround
1. Modify C:\Program Files\FMEServer\Config\values.yml
- Open C:\Program Files\FMEServer\Config\values.yml in a text editor
- Change systemuser: "Systèm" to systemuser: "Systeme" to remove the special character.
- Edit the line oraclepassword: <<POSTGRES_ROOT_PASSWORD>> to postgresrootpassword: "postgres" (There is a bug in the password redaction code that changes this keyname to "oraclepassword"). If you would like a more secure root password for the database, enter a different value instead of "postgres".
- Replace all occurrences of <<DATABASE_PASSWORD>> with "fmeserver", or if you would like a different database password, use that value.
- Save the file.
2. Run Commands in Command Prompt
Open a command prompt as Administrator and run the following commands.
The commands are pointing to the default location for FME Server directory, please account for paths if you have custom or changed the FME Server directory location during installation.
- cd "C:\Program Files\FMEServer\Config\confd"
- confd.exe -onetime -backend file -file ..\values.yml -confdir .
- "C:\Program Files\FMEServer\Utilities\initPostGreSQL.bat"
3. Run Commands in Powershell
Open a powershell windows as Administrator and run the coommand:
- & 'C:\Program Files\FMEServer\Utilities\setupPostGreSQL.ps1'
4. Start FME Server
Start the FME Server services in Windows Services (FME Server Application Server, FME Server Core, FME Server Database, and FME Server Engines).
5. Reinstall FME Server if Issue Persists
If the FME Server login page does not show fields for username and password, this indicates connection issues with the FME Server database. Please uninstall and reinstall FME Server to resolve the issue.
Comments
0 comments
Please sign in to leave a comment.