Known Issue: Errors or Issues with FME Server Distributed Installation over Multiple Timezones

Liz Sanderson
Liz Sanderson
  • Updated

Symptoms

There may be a variety of symptoms for this issue dependent and how and what FME Server components have been distributed.

  1. Pop up notification ' Authentication Failed' (despite being successfully logged in) and errors in the processmonitorengine.log file "Failed login by user 769475cda6eacaa922b7a60aabcfd8e0a91bf6d8 due to insufficient credentials."
  2. FME Server token renewal may occur at different times (too early or late)
  3. Improper timing of Schedule Initiated triggers.
  4. Inconsistent or misleading timestamps in log files (accessed from Resources)

Cause

  1. There is a timezone mismatch between distributed components.
  2. If a Session Token is created from FME Workbench it will use the local time of FME Server and will compare against the local time of FME Workbench.
  3. There is a timezone mismatch between distributed components.
  4. There is a timezone mismatch between distributed components.

Resolution

  1. Install the FME Server distributed engine on a machine in the same time zone as the FME Server Core
  2. Returning the expiry time in seconds may resolve the issue.
  3. Install all FME Server components with the same time zone.
  4. Install all FME Server components with the same time zone.

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