Symptoms
There may be a variety of symptoms for this issue dependent and how and what FME Server components have been distributed.
- Pop up notification ' Authentication Failed' (despite being successfully logged in) and errors in the processmonitorengine.log file "Failed login by user 769475cda6eacaa922b7a60aabcfd8e0a91bf6d8 due to insufficient credentials."
- FME Server token renewal may occur at different times (too early or late)
- Improper timing of Schedule Initiated triggers.
- Inconsistent or misleading timestamps in log files (accessed from Resources)
Cause
- There is a timezone mismatch between distributed components.
- If a Session Token is created from FME Workbench it will use the local time of FME Server and will compare against the local time of FME Workbench.
- There is a timezone mismatch between distributed components.
- There is a timezone mismatch between distributed components.
Resolution
- Install the FME Server distributed engine on a machine in the same time zone as the FME Server Core
- Returning the expiry time in seconds may resolve the issue.
- Install all FME Server components with the same time zone.
- Install all FME Server components with the same time zone.
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