FME Version
Symptom
In the FME Server Web UI when I try and view Resources or Broadcast Messages the page is blank and I see an error pop up stating “We couldn't find what you wanted”
In addition, in Automations I can add a trigger/external action but cannot set the protocol type and if I try and view an existing Automation nothing is displayed in the canvas.
Lastly in the Catalina.log there is a severe warning regarding the failure to deploy a WAR file.
SEVERE [Catalina-utility-1] org.apache.catalina.startup.HostConfig.deployWAR Error deploying web application archive
Causes and Resolutions
There are three known causes for this error outlined below. Please review and check each solution prior to contacting Support.
Cause 1
You may experience this behaviour in FME Server 2020.0 if your FME Server installation has either a distributed database or web application server. The web application configuration is not set up correctly to reference the database so it cannot find some components.
Resolution
- On the host machine where the FME Server Web Application Service is installed find the fmeServerWebApplicationConfig.txt, this is located in InstallDir>\FMEServer\Server\.
- Scroll to the bottom of the file until you find the Database Connection section.
- Update the DB_JDBC_URL parameter value so that it correctly references the host machine the FME Server Database is installed on
E.g.
INCORRECT
DB_JDBC_URL=jdbc:postgresql://:7082/fmeserver
CORRECT
DB_JDBC_URL=jdbc:postgresql://<database_hostname>:<port>/fmeserver
Note you'll need to replace <database_hostname>:<port> with your database information. - Verify that your connection parameter values match with the database connection parameters in the fmeCommonConfig.txt
- Restart the FME Server Web Application Service to apply these changes.
If you have correctly configured your fmeServerWebApplicationConfig.txt file but continue to encounter this issue, you may need to upgrade your FME Server.
Windows: Please use FME Server 2020.0.0.1 (Build 20202) or newer.
Linux: Please use FME Server 2020.0.1 (Build 20218) or newer.
Cause 2
If you have performed an Express Install of FME Server 2020.0 but then proceeded to update the database password, the database password needs to be updated in the configuration files.
Resolution
- On the host machine where the FME Server Web Application Service is installed find the fmeServerWebApplicationConfig.txt, this is located in InstallDir>\FMEServer\Server\.
- Scroll to the bottom of the file until you find the Database Connection section.
- Update the DB_PASSWORD parameter that corresponds to DB_TYPE=postgresql with the new password.
- Restart the FME Server Web Application Service to apply these changes.
Cause 3
You may encounter this when using your own custom database and are providing a JDBC Driver to connect to the database. For example, this may occur when supplying an Oracle JDBC Driver (ojdbc#.jar) during the installation of FME Server because you wish to use Oracle for the FME Server Database. The installer only copies the jdbc driver to one location but is required in two locations.
Resolution
Locate the JDBC Driver <InstallDir>FMEServer\Utilities\jdbc and copy it into the <InstallDir>FMEServer\Utilities\tomcat\lib folder.
This issue has been fixed for FME Server 2020.2 Build 20802 or newer.
Comments
0 comments
Please sign in to leave a comment.