FME Version
Known Issue ID | FMESERVER-16503 |
---|---|
Discovered | 2021.0 b21302 |
Affects | 2021.0 b21302+ |
Resolved | 2021.0.1 b21313 |
Symptom
After creating a backup file in FME Server 2020.x or older then performing a System Restore on FME Server 2021.0, you observe some or all of the following:
- When a Job is submitted it does not run and remains in the 'Queued' state. You'll find the job on the “Jobs” page within the Web Interface, under the Queued tab, and if you click on the job to view the details there is no log file and it remains QUEUED.
- On the “Jobs” page within the Web Interface, jobs appear under the Queued tab.
- Within Engine Management > Engines, the Default queue is not associated with any engines.
You have not performed a System Restore, but after creating a new Queue and Engine Assignment Rule that applies to all engines:
- When some (or all) jobs are run, they do not complete.
- Within Engine Management > Engines, the Default queue is not present on any engines.
Cause
In FME Server 2021.0 Queue functionality was completely rewritten. When a new Engine Assignment Rule is created by the restore process or manually, any engines assigned to the new queue are removed from the Default queue.
If you have not set up Job Routing Rules to the new Queue, Jobs will continue to attempt to run under the Default queue.
Workaround
Option 1: Assign Engines to the Default Queue
On the Engine Management page under Engine Assignment Rules, create a new rule to assign the engines to the Default Queue
Option 2: Create a Job Routing Rule to the new Queue
On the Engine Management page under Job Routing Rules, create a new rule to route Jobs to your new queue.
Resolution
FME Server 2021.0.2 (Build 21309) or greater:
- The Default queue configuration from a source server (2020.x or older) will be preserved after a System Restore on the destination server (2021.x or newer) when Overwrite = "False". The following warning message will inform the user of this behaviour:
WARN Thread-10 409817 : Overwrite Existing Items is not checked. However, to maintain backward compatibility with FME Server 2020 or earlier, this restore operation will overwrite the Default queue configuration onto the restored instance. All other items on the restored FME Server will not be overwritten.
- The Default queue configuration from a source server (2021.x or newer) will not be preserved after a System Restore on the destination server (2021.x or newer) when Overwrite = "False".
Troubleshooting
If managing Queue Control settings does not resolve the issue OR you are using an older version of FME Server (2020.x or older), the FME Engines may be Unavailable.
Consult our general FME Server Troubleshooting Guide for more ideas or refer to How to Create a Great FME Server Support Case to get started making a case with us.
Comments
0 comments
Please sign in to leave a comment.