FME 2023 Workspace fails to load ArcPy with ArcGIS Pro 2.6/ArcGIS Server 10.8.1 or prior

Debbi L
Debbi L
  • Updated

FME Version

  • FME 2023.0

Affects

  • FME Form 2023 (formerly FME Desktop) when ArcGIS Pro 2.1 - ArcGIS Pro 2.6 is installed on the same machine
  • FME Flow 2023 (formerly FME Server) when ArcGIS Server 10.6 - 10.8.1 is installed on the same machine.

Introduction

Python 3.6.15 was the final security fix release of Python 3.6, per PEP494, the Python 3.6 release schedule:

As of 2021-12-23, 3.6 has reached the end-of-life phase of its release cycle. 3.6.15 was the final security release. The code base for 3.6 is now frozen and no further updates will be provided nor issues of any kind will be accepted on the bug tracker.

FME users running Desktop or Server editions prior to and including FME 2022 may have developed workspaces that call ArcPy using a version of ArcGIS that supports Python 3.6 (ArcGIS Pro 2.1 - 2.6; ArcGIS Enterprise 10.6-10.8.1). When FME is upgraded to FME 2023, users will encounter an error due to FME 2023 sunsetting support for Python 3.6.

 

Symptoms

Form 2023 users will see the following error message:
 

ERROR : Installed version of ArcGIS Pro '2.6' is unsupported. Esri Python Compatibility supports ArcGIS Pro versions '2.7' to '3.1'


ERROR : A compatible ArcGIS application could not be found or is not licensed for Python Compatibility 'Esri ArcGIS Python 3.6+'


The workspace has Python Compatibility set to 'Esri ArcGIS Python 3.6+', which requires an appropriate version of ArcGIS Pro or ArcGIS Server. If ArcGIS is not required by this workspace, then update Python Compatibility to a non-Esri-ArcGIS Python. Otherwise, please install the required ArcGIS product. Please visit https://community.safe.com/s/article/notes-on-fme-and-esri-versions-and-compatibility for supported ArcGIS products and versions with FME. To update this setting, go to: Navigator -> Workspace Parameters -> Scripting -> Python Compatibility

 

Flow 2023 users will see the following error message:
 

The workspace has Python Compatibility set to 'Esri ArcGIS Python 3.6+', which requires an appropriate version of ArcGIS Pro or ArcGIS Server. If ArcGIS is not required by this workspace, then update Python Compatibility to a non-Esri-ArcGIS Python. Otherwise, please install the required ArcGIS product. Please visit https://community.safe.com/s/article/notes-on-fme-and-esri-versions-and-compatibility for supported ArcGIS products and versions with FME. To update this setting, go to: Navigator -> Workspace Parameters -> Scripting -> Python Compatibility


Workaround

If ArcGIS is not required by this workspace, then update Python Compatibility to a non-Esri ArcGIS Python option. Otherwise, please install a compatible ArcGIS product.

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.