FME Server appears to hold connections open or licenses checked out for longer than expected.

Liz Sanderson
Liz Sanderson
  • Updated

Symptom

Run a workspace on FME Server that requires an ArcGIS license. Then when you try to use the license elsewhere (e.g. ArcCatalog) it isn't available.

Or run a workspace on FME Server that opens a connection to an Oracle database and find that the connection is held open even after the workspace completes.

Cause

The FME Engine process keeps the license until the process is stopped. FME is calling the ArcGIS API shutdown, but the license is still not being checked in.

Similarly the database connection is not closed because chances are that you may run a second workspace with the same connection parameters and it will run faster if we don't have to reopen the connection.

Resolution

By default, the FME Engine processes restart after 100 successful translations or after 10 failed translations. You will see this message in the logfile.

"Max translation result successes reached. Restarting FME Engine."

You can tell the FME Engine to restart after every translation by doing the following:

  • Open the following file in a text editor:
 <FMEServerDir>\Server\fmeServerConfig.txt

  • Locate the following parameters and change their values to 1:
MAX_TRANSACTION_RESULT_SUCCESSES=100

MAX_TRANSACTION_RESULT_FAILURES=10

  • Restart FME Server

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.