Known Issue: FMEJobSubmitter unable to connect to FME Server after upgrading to 2021.x

Liz Sanderson
Liz Sanderson
  • Updated

FME Version

Known Issue ID FMESERVER-17662
Discovered 2021.0
Affects 2021.0 and newer
Resolved N/A

Symptom

After upgrading FME Server from 2020.x or older to 2021.x or newer the FMEServerJobSubmitter fails to submit jobs. The error in the parent log file is: 

FMEServerJobSubmitter (ServerFactory): https://<FMESERVER> - Submitting a request to run workspace 'austinApartments.fmw' in repository 'Samples'...
FMEServerJobSubmitter (ServerFactory): https://<FMESERVER> - Failed to submit request to run workspace 'austinApartments.fmw' in repository 'Samples'
FMEServerJobSubmitter (ServerFactory): Reason - unable to connect to FME Server 'https://<FMESERVER>'

 

Cause 

A new parameter ‘Verify SSL Certificates’ was introduced on the FME Server Web Connection configuration in FME Desktop 2021. This parameter isn’t currently exposed in the FME Server Web UI and the value set for this parameter is being saved in the web service definition rather than the individual connection. 

If the web service has been restored from FME Server 2020.x or older, this parameter is being set to ‘Yes’ by default. Since it’s set in the web service definition, any new FME Server connections published in 2021 after a restore will also try to verify SSL certificates, because the web service does not get overwritten when new connections are published. If the SSL certificate cannot be verified FME Server will return the above error.

 

Resolution

Option 1: Import your SSL Certificate via Internet Options

  1. Export your certificate from the web browser
    1. Open a Web browser > Load FME Server > View the certificate details
      View Certificate.png
    2. Select ‘Copy to File…’
      CopyToFIle.png
    3. Save as a “Base-64 encoded X.509 (CER)” to local disk (e.g. <certpath>\mycert.cer)
      Base64.png
  2. Import the certificate downloaded in step 1 to Internet Options > Content > Certificates > Import.
    ImportCert.png
  3. Restart your web browser and resubmit the parent workspace to verify the fix. 

Option 2: Remove and re-publish the Web Service Definition

  1. Through the FME Server UI go to Files & Connections > Web Connections > Manage Web Services > check the box next to the FME Server connection and select Remove. 
  2. In FME Workbench 2021 open the workspace containing the FMEServerJobSubmitter and publish it. This will reload the Web Service definition so that the Verify SSL parameter is correctly set to ‘No’. 
  3. Return to FME Server and resubmit the workspace to verify the fix. 

Note: By removing the FME Server Web Service all associated FME Server web connections will also be removed. Before you perform step 1, consider creating and exporting a project file that contains all your FME Server web connections. This way they can be re-imported after the web service definition has been corrected.


Option 3: Embed connection details

  1. In FME Workbench open the parent workspace.
  2. In the FMEServerJobSubmitter transformer update the Connection to ‘Embed Connection Parameters’ and complete the associated parameters.
  3. Publish the workspace to FME Server and run it to test the workspace.

Note: Using this option your workspace is no longer making use of a web connection, so it is recommended to use this option only as a last resort. 



 

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.