FME Version
Known Issue ID | FMESERVER-15328 |
---|---|
Discovered | 2021.0 b21160 |
Affects | 2021.0+ |
Resolved | 2021.0 b21212 |
Symptom
Attempting to remove a Directory Server you are prompted to remove all associated user accounts/roles and the request fails with an 'Internal Server Error' toast message.
The Directory Server has not been removed and some but not all user accounts/roles remain as well.
Trying to remove the Directory Server a second time you may see another toast message error 'Unable to parse value "[object Object]" for parameter "id".
Cause
This can happen when your FME Server is configured with a Microsoft SQL Server or Oracle Database. The database encounters a deadlocking issue attempting to delete multiple users on either the fme_useraccount or fme_role tables. To confirm this is the issue you have encountered, review the restV4.log located in Resources > Logs > Services > Current | Old, and if connecting to an SQL Server Database look for an error similar to:
com.microsoft.sqlserver.jdbc.SQLServerException: Transaction (Process ID 53) was deadlocked on lock resources with another process and has been chosen as the deadlock victim. Rerun the transaction.
If using an Oracle Database the error will look like:
COM.safe.fmeserver.api.FMEServerException: java.sql.SQLException: ORA-00060: deadlock detected while waiting for resource
Resolution
Remove the remaining Users/Roles separately before attempting to remove the Directory Server.
Comments
0 comments
Please sign in to leave a comment.