Known Issue: Third-Party Plug-in Incompatibility

Liz Sanderson
Liz Sanderson
  • Updated

FME Version

  • FME 2022.0
Known Issue IDFMEENGINE-73151
DiscoveredFME 2022
AffectsFME 2022.0 and newer
ResolvedSee the resolution section


A message similar to the following will appear in the log when FME 2022.0 attempts to load a C++ plug-in compiled with FME 2021 or older:
FME API version of module 'PLUGIN’ is '3.8 20200115', and it is incompatible with FME internal API version '4.0 20220317'
where 'PLUGIN' is the name of the third-party plugin (eg. gti/GTI_GTViewer)


The C++ APIs for developers have undergone some changes for FME 2022.0 and newer. Reader/Writer and Transformer plug-ins written in C++ will need to be recompiled with FME 2022 in order to be compatible with FME 2022 and newer. 


If you encounter this issue, please contact the developer of the third-party plug-in to obtain an updated version of the plug-in, compiled with the FME 2022.0 or newer.

Was this article helpful?



Please sign in to leave a comment.