Known Issue: Authentication Services Page Gives 500 Internal Error after 2021.x to 2023.x Backup and Restore

Bailey K
Bailey K
  • Updated

FME Version

Known Issue ID FMEFLOW-21836
Feature Backup and Restore
Product FME Flow (formerly FME Server)
Versions Affected

2023.1

2023.0

2022.x

2021.x

Status

Resolved

2023.2

Issue 

When upgrading FME Flow from 2021.x to 2023.x and performing a backup and restore, User Management > Authentication Services is inaccessible and returns an Internal Server Error. 

 

Cause

This issue occurs after creating a backup in a 2021.x version of FME Server and restoring it to a 2023.x FME Flow. When navigating to User Management > Authentication Services on the 2023.x FME Flow, an “Internal Server Error” message pops up and the screen stays greyed out with a loading icon. The HAR log says 500 Internal Error. 
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AD-imported users are able to log in but they cannot access the authentication services page or create another connection. 

This issue is caused by the parsing of redundantServers parameter for LDAP servers in a V4 GET call. 

 

Workaround

The workaround is to update the redundantServers property for the affected LDAP server. You will need to know the name of the server. 
1. Navigate to the APIs found  in the Help & Resources question mark icon > REST API. Once on the page, request a token on the top right with Get Token. 
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2. In the API tab, navigate to Security and select Expand Operations. 
3. Find the PUT call  /security/ldap/servers/<server> (description Update an LDAP Server) and expand. Here you will fill out two fields in the API form: server and redundantServers. 

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4. Enter the name of the LDAP server that is affected in the server field. In the redundantServers field, enter in a valid string such as 123;123. 
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5. Click Try it out! To send the API request and you should see a response code of 204

This will unblock the Authentication Services and you should be able to view your LDAP servers. In the server’s details, you can go to Optional fields and remove the redundant server that was added under Alternate Servers. 
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Note: If you have multiple LDAP servers configured, you can get them all through the REST API via the GET call /security/ldap/servers. This will return a list of LDAP servers and any server that has an empty string in the redundantServers field "redundantServers": "" which will need to go through the workaround.
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