Symptom
- Reboot a Windows machine, and the FME Flow web interface doesn't allow you to log in.
- Check Windows services: FME Flow Database service is not running.
- Starting the service manually fails.
- Check Windows event viewer and see errors like:
- lock file "postmaster.pid" already exists
- pg_ctl: this data directory appears to be running a pre-existing postmaster
Cause
The issue is tied to the PostgreSQL database, the underlying database that FME Flow uses.
Resolution
To correct this issue, open the Windows task manager and end all processes/services with the name "postgres".
Restart all FME Flow services using the directions listed here: Working with the System Services. The Database service should now start, and you should be able to log in.