FME Flow Database Service Does Not Start After Reboot

Liz Sanderson
Liz Sanderson
  • Updated

Symptom

  1. Reboot a Windows machine, and the FME Flow web interface doesn't allow you to log in.
  2. Check Windows services: FME Flow Database service is not running.
  3. Starting the service manually fails.
  4. Check Windows event viewer and see errors like:
    • lock file "postmaster.pid" already exists
    • pg_ctl: this data directory appears to be running a pre-existing postmaster

Cause

The issue is tied to the PostgreSQL database, the underlying database that FME Flow uses.

Resolution

To correct this issue, open the Windows task manager and end all processes/services with the name "postgres".

Restart all FME Flow services using the directions listed here: Working with the System Services. The Database service should now start, and you should be able to log in.

Was this article helpful?

We're sorry to hear that.

Please tell us why.

As of January 14th, 2026, comments on knowledge base articles have been closed. To make sure questions don’t get missed and to enable more community support, we’ve moved discussions to the FME Community. If you have a question or a comment about this article, please create a new post or create a support ticket.