Symptom
I see the 401 Client Error: Unauthorized for URL error in my translation or job log.
Cause
This is typically due to an expired ArcGIS Online connection or, if encountered on FME Server, an invalid ArcGIS Online web service.
Resolution
Please see the steps below for FME Desktop and FME Server. To prevent the ArcGIS Online web connection from expiring in the future, ensure a workspace using it is run at least every two weeks to refresh the underlying token; otherwise, you will need to reauthenticate the web connection in FME Workbench.
FME Desktop
If the connection previously worked and has started to fail, try to reauthenticate the connection. To Reauthenticate, select Tools in the top toolbar and then select FME Options. Select Web Connections on the left-hand side of FME Options. Find your ArcGIS Online Web connection, right-click on it, and select Reauthenticate.
Note: by default, ArcGIS Online tokens last 14 days, but this value can be changed by an Administrator. If you find you are frequently needing to reauthenticate, please check with your ArcGIS Online administrator.
FME Server
If you see this error on FME Server, it is likely for one of two reasons.
1. The ArcGIS Online Web Connection has Expired
The first reason is that the connection to ArcGIS Online has expired. If this happens, manually refresh the connection:
Go to the Web Connections page in FME Server and click on the connection.
Click Authorize. if this button is greyed out, the web connection has not been configured for FME Server. Proceed to the next section.).
2. The ArcGIS Online Web Connection has not been configured for FME Server
If the web connection cannot be reauthorized because the button is disabled, as shown below, then the web connection is not set up properly for FME Server. The instructions can be found in the article How to create ArcGIS Online Web Connection for FME Server (OAuth 2.0)
If this does not work for you, it is likely that you are encountering a network issue connecting to ArcGIS Online. If you are using a proxy, please verify that your proxy settings are set in the FME Server UI . If you are still unable to connect, please submit a support case.
Comments
1 comment
Hi Sienna, thanks for the Known Issue article. You mentioned “by default, ArcGIS Online tokens last 14 days” within the FME Desktop part. I guess this applies also to FME Server?
Best regards
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