Known Issue: AutodeskDocsConnector OAuth API v1 Deprecation will Require an Upgrade to FME 2023.2

Jovita C.
Jovita C.
  • Updated

FME Version

  • FME 2023.2
Known Issue ID FMEENGINE-79894
Discovered FME 2023.0
Affects FME 2023.1 and older
Resolved FME 2023.2
AutodeskDocsConnector v1.1.0

Symptom

After April 30th, 2024, the AutodeskDocsConnector and web service will cease to work if you are running it in FME 2023.1 and older for both existing workspaces and newly created web connections.
 

Cause

With Autodesk deprecating their OAuth v1 and moving to v2 by the end of April 30th, 2024, this will cause a disruption to existing web services such as our AutodeskDocsConnector.
 

Resolution

Our team has upgraded the web services infrastructure for FME Form and FME Flow to work successfully with Autodesk’s new v2 authentication.

This means that for FME users, you will need to upgrade to a minimum version of FME 2023.2 and install the latest available AutodeskDocsConnector package (v 1.1.0 and newer) to be able to access files in your Autodesk Construction Cloud or through BIM 360.  
 

Was this article helpful?

Comments

0 comments

Please sign in to leave a comment.